Users experiencing slowness in Hubdoc
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing slowness in Hubdoc.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Dec 02, 2020 - 02:56 UTC
Monitoring
We are no longer seeing errors related to this issue.

We will continue to monitor this and update you here.
Posted Dec 02, 2020 - 01:16 UTC
Identified
Our Product Team have identified the cause, and are working to restore your ability to use Hubdoc as soon as possible.
Posted Dec 01, 2020 - 23:23 UTC
Investigating
We're currently aware of an issue for users, experiencing slowness in Hubdoc. Our Product Team is currently looking into this.
Posted Dec 01, 2020 - 22:51 UTC
This incident affected: Hubdoc.