Some users are experiencing slowness and errors when accessing Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 07:52 UTC
Update
We will continue to keep you updated as our teams work to solve this and we apologise for this inconvenience which we acknowledge is very frustrating.
Posted Jul 21, 2020 - 07:36 UTC
Update
We understand this is disrupting your day and we are sorry. Please bear with us as our teams work to investigate and solve this.
Posted Jul 21, 2020 - 06:59 UTC
Update
Our teams are working to investigate and solve this and we will keep you updated as soon as we know more.
Posted Jul 21, 2020 - 06:10 UTC
Update
We’re continuing to investigate this and understand your frustration. Thank you for your patience.
Posted Jul 21, 2020 - 05:19 UTC
Update
We’re sorry this is causing problems. Thank you for your support while we fix this for you.
Posted Jul 21, 2020 - 04:32 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Jul 21, 2020 - 03:51 UTC
Update
Our Product Team are doing everything they can to let you access Xero. Thanks for your patience.
Posted Jul 21, 2020 - 03:30 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Jul 21, 2020 - 03:02 UTC
Investigating
We're aware of an issue where some users are experiencing errors and slowness when accessing Xero.

Our Product team are looking into this with urgency and we'll let you know when we have any updates.

We apologise for any inconvenience this is causing you.
Posted Jul 21, 2020 - 02:28 UTC
This incident affected: Xero Platform and Settings.