Xero Navigation Bar - Slow performance when accessing Reports tab
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access Reporting.

We are aware that customers experienced slowness loading the Report centre in Xero during this incident. This was caused by a network connectivity issue with a system that Xero uses and the team has focussed on building resilience between these two systems so this does not occur again.

We apologise for any inconvenience this caused.
Posted Aug 17, 2022 - 07:02 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 5.53am UTC
Posted Aug 17, 2022 - 05:53 UTC
Update
We are continuing to investigate this issue.
Posted Aug 17, 2022 - 01:03 UTC
Investigating
We are aware that all customers trying to navigate in Xero are experiencing performance issues when accessing the Reports tab. Our team is investigating this with urgency.

Status Last Reviewed: 4:56AM UTC
Posted Aug 17, 2022 - 00:26 UTC
This incident affected: Xero Platform and Settings.