Some users are unable to send, download and print invoices
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from sending, downloading and printing invoices.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Oct 18, 2021 - 16:49 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Oct 18, 2021 - 16:35 UTC
Identified
Our Product Team have identified the cause, and are working to restore your ability to send, download and print invoices as soon as possible.
Posted Oct 18, 2021 - 16:21 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Oct 18, 2021 - 16:18 UTC
Investigating
We're currently aware of an issue where users are unable to send, download and print invoices. Our product team is looking into this with urgency and we'll update you as we have more information.
Posted Oct 18, 2021 - 16:05 UTC
This incident affected: Xero Platform and Settings.