We’re currently aware of an issue causing users to experience slowness and errors in Invoicing.
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing errors and preventing some users from accessing Invoicing in Xero.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Oct 26, 2021 - 11:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2021 - 10:52 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Oct 26, 2021 - 10:44 UTC
Investigating
We’re currently aware of an issue preventing users from accessing Invoicing in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Oct 26, 2021 - 10:15 UTC
This incident affected: Xero.