Australian users are unable to view their subscription page in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from viewing the subscription page and making subscription changes for their organisations.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Sep 22, 2020 - 22:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 22, 2020 - 22:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2020 - 22:36 UTC
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted Sep 22, 2020 - 22:00 UTC
Update
We're currently working to get the Subscription page back up for everyone.

Thanks for your continued patience.
Posted Sep 22, 2020 - 21:27 UTC
Identified
Our Product Team have identified the cause, and are working to restore your ability to view the subscription page as soon as possible.
Posted Sep 22, 2020 - 20:55 UTC
Investigating
We’re currently aware of an issue preventing Australian customers from viewing the subscription page and making subscription changes for their organisations.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Sep 22, 2020 - 20:40 UTC
This incident affected: Xero Platform and Settings.