Xero HQ - Client list taking around 20 minutes to update
Incident Report for Xero
Resolved
This incident has been resolved.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Mar 15, 2023 - 04:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 04:06 UTC
Identified
We have identified what is impacting customers updating the client list in Xero HQ.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 3:33am UTC
Posted Mar 15, 2023 - 03:33 UTC
Investigating
We are aware of an issue where customers trying to update the client list in Xero HQ are experiencing around a 20 minute delay. Our team is investigating this with urgency.

Status Last Reviewed: 2:19am UTC
Posted Mar 15, 2023 - 02:20 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).