Global: Xero - Customers are experiencing latency in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue causing slowness across Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Nov 17, 2023 - 03:07 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 3:03am UTC.
Posted Nov 17, 2023 - 03:03 UTC
Investigating
We are aware that customers are experiencing latency in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 2:29am UTC.
Posted Nov 17, 2023 - 01:57 UTC
This incident affected: Xero Platform and Settings.