Global: Reporting - Errors loading reports

Incident Report for Xero

Resolved

Our team has resolved the issue some customers were experiencing trying to load reports. We apologise for any inconvenience caused.
Posted Jun 05, 2026 - 16:30 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted Jun 05, 2026 - 16:08 UTC

Investigating

We are aware that some customers trying to load reports are experiencing error messages or pages not loading. Our team is investigating this with urgency.
Posted Jun 05, 2026 - 15:47 UTC
This incident affected: Core Xero Products (Reporting).