NZ, AU, UK Payroll - Currently a delay sending emails with files attached
Incident Report for Xero
Resolved
This incident has been resolved.

This was caused by a queue in our email systems and was cleared after 20 minutes.
Posted Mar 16, 2023 - 01:16 UTC
Investigating
We are aware of an issue where there is a delay with customers sending an email within payroll. Our team is investigating this with urgency.

Status Last Reviewed: 12:47am UTC
Posted Mar 16, 2023 - 00:21 UTC