Global: Xero- some customers may be experiencing issues in Xero

Incident Report for Xero

Resolved

Our team has resolved the issue affecting customers trying to access Xero. We apologise for the disruption this, and the other incidents today, have caused. We know how important reliable access to Xero is for you, and we appreciate your patience.
Posted May 06, 2026 - 04:25 UTC

Identified

We have identified what is preventing customers from navigating in Xero. This is our top priority and we will update you as soon as we can.
Posted May 06, 2026 - 03:56 UTC

Investigating

We are aware some customers trying to access Xero are experiencing an error. Our team is investigating this with urgency.
Posted May 06, 2026 - 03:54 UTC
This incident affected: Xero Platform and Settings.