Global: Xero HQ - customers unable to access the Overview page
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access the Overview page in Xero HQ. This was caused by the Practice Overview page becoming unstable, causing degraded performance when customers tried to load the page. The system self detected the instability and restarted the service to resolve impact to customers.

We apologise for any inconvenience this has caused.
Posted Jan 25, 2023 - 03:25 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Posted Jan 25, 2023 - 03:24 UTC
Investigating
We are aware customers trying to access the Overview page in Xero HQ are experiencing issues loading the page. Our team is investigating this with urgency.

Status Last Reviewed: 3:25am UTC
Posted Jan 25, 2023 - 02:59 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).