Global: Xero HQ - Some customers are experiencing errors or slowness when navigating XPM and Xero HQ

Incident Report for Xero

Resolved

Our team has resolved the issue impacting some partners when navigating XPM and Xero HQ. We apologise for any inconvenience this has caused.
Posted Jul 23, 2026 - 07:59 UTC

Update

Our team has resolved the issue impacting some partners when navigating XPM and Xero HQ. We apologise for any inconvenience this has caused.
Posted Jul 23, 2026 - 05:10 UTC

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 04:49 UTC

Investigating

We are aware of some customers experiencing slowness or receiving errors when navigating Xero HQ. Our team is investigating this with urgency.
Posted Jul 23, 2026 - 04:46 UTC
This incident affected: Xero Partner Products & Tools (Workpapers, Xero Practice Manager (XPM), Xero HQ, Xero Tax (AU), Xero Tax (NZ), Xero Tax (UK)).