Some users are experiencing slowness in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing users to experience slowness in Xero.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Mar 16, 2020 - 20:03 UTC
Monitoring
Our Product Team is continuing to monitor the conditions that have been causing some slowness and timeouts recently. We appreciate your patience, and are sorry for any inconvenience caused.
Posted Mar 14, 2020 - 05:50 UTC
Update
We’re sorry this is causing you some downtime. Thank you for your support while we fix this for you.
Posted Mar 14, 2020 - 05:13 UTC
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted Mar 14, 2020 - 04:25 UTC
Update
We're currently working to get intermittent issues fixed for everyone. Thanks for your continued patience.
Posted Mar 14, 2020 - 03:56 UTC
Identified
Our Product Team have identified the cause, and are working to restore your ability to access Xero as soon as possible.
Posted Mar 14, 2020 - 03:08 UTC
Update
Our Product Team are doing everything they can to let you access Xero. Thanks for your patience.
Posted Mar 14, 2020 - 01:49 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Mar 14, 2020 - 01:06 UTC
Investigating
We’re currently aware of some intermittent issues impacting some of our users, which may be causing slowness and errors when using xero. Our product team is investigating this with urgency.

We apologise for the inconvenience this is causing you.
Posted Mar 14, 2020 - 00:27 UTC
This incident affected: Xero.