Global: Xero Practice Manager - customers may be experiencing slowness

Incident Report for Xero

Resolved

Our team has resolved the issue impacting our customers trying to navigate in Xero Practice Manager. We apologise for any inconvenience this has caused.

We learn from every incident and put measures in place to prevent issues from happening again

Within 24 hours we’ll update this page with a brief summary
Posted Apr 01, 2025 - 03:16 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 2:36am UTC
Posted Apr 01, 2025 - 01:56 UTC

Identified

We have identified what is impacting our customers experiencing a slowness in Practice Manager.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 1:35am UTC
Posted Apr 01, 2025 - 01:31 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM), Xero Tax (AU), Xero Tax (NZ)).