Mailgun delay
Incident Report for Xero
Resolved
Our email service provider have resolved the issue resulting in delays of outgoing emails sent from Xero.
Posted Jun 03, 2021 - 16:59 UTC
Update
Our email service provider have implemented a fix for the delays in sending emails. Email receipt times are improving and we're continuing to monitor the situation.
Posted Jun 03, 2021 - 15:47 UTC
Monitoring
We're currently aware of an issue where some customers are experiencing a delay in emails sent through Xero. Our email service provider are currently aware of the issue and have implemented a fix. We'll keep you updated with any progress.
Posted Jun 03, 2021 - 14:32 UTC
This incident affected: Xero Platform and Settings.