Global: XPM - Customers may be experiencing slowness in XPM
Incident Report for Xero
Resolved
Our team has resolved the issue which was causing customers to experience slowness in XPM. This issue related to a network connectivity issue which our team implemented a fix for to resolve customer impact. We apologise for any inconvenience this has caused.
Posted May 14, 2024 - 00:45 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12.22am UTC
Posted May 14, 2024 - 00:22 UTC
Investigating
We are aware customers trying to access XPM are experiencing slowness. Our team is investigating this with urgency.

Status Last Reviewed: 12:07am UTC.
Posted May 13, 2024 - 23:36 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).