Philippines - Some customers may be experiencing errors in Xero due to an internet service connection issue

Incident Report for Xero

Resolved

Our team has received confirmation that the issue impacting customers based in the Philippines on a speicific internet service provider from accessing Xero has been resolved.

We recommend reaching out to your internet service provider if you are experiencing any further issues.
Posted Sep 25, 2025 - 02:07 UTC

Identified

We've contacted the internet service provider for more information.

Customers can access Xero via mobile data or another internet service provider as normal.

Status Last Reviewed: 7.22PM UTC
Posted Sep 24, 2025 - 07:25 UTC
This incident affected: Xero Platform and Settings.