Global: Xero - Some customers experiencing performance issues
Incident Report for Xero
Resolved
Our team has resolved the issue causing some to customers experience performance issues and error messages in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 05, 2023 - 12:04 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: UTC 11:39
Posted Sep 05, 2023 - 11:39 UTC
Investigating
We are aware that some customers experiencing performance issues and error messages in Xero. Our technical teams are investigating as a matter of urgency.

Status Last Reviewed: UTC 11:03
Posted Sep 05, 2023 - 10:42 UTC
This incident affected: Xero Platform and Settings.