Our team has resolved the issue causing general slowness across the Xero platform. This was caused by a recent release and a simultaneous increase in Xero usage. We apologise for any inconvenience this has caused.
Posted Oct 09, 2023 - 00:18 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 12:07am UTC
Posted Oct 09, 2023 - 00:07 UTC
Identified
We have identified what is causing general slowness across the Xero platform.
This is our top priority and we will update you as soon as we can.
Status Last Reviewed: 11:43pm UTC
Posted Oct 08, 2023 - 23:44 UTC
Investigating
We are aware customers are currently experiencing general slowness across the Xero platform. Our team is investigating this with urgency.
Status Last Reviewed: 11.17pm UTC
Posted Oct 08, 2023 - 23:17 UTC
This incident affected: Xero Platform and Settings.