Some users are experiencing slowness in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing users to experience slowness in Xero.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Sep 09, 2020 - 21:38 UTC
Update
We’re sorry this is causing you some downtime. Thank you for your support while we fix this for you.
Posted Sep 09, 2020 - 21:21 UTC
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted Sep 09, 2020 - 15:03 UTC
Update
We're currently working to get the affected users back up and running. Thanks for your continued patience.
Posted Sep 09, 2020 - 10:03 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 09, 2020 - 05:18 UTC
Identified
Our Product Team have identified the cause, and are working to restore full performance as soon as possible.
Posted Sep 09, 2020 - 03:55 UTC
Investigating
We’re currently aware of an issue where some users are experiencing slowness when using Xero.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Sep 09, 2020 - 03:26 UTC
This incident affected: Xero.