Some users experiencing performance issues in Xero Practice Manager (XPM)
Incident Report for Xero
Resolved
Our team has resolved the performance issues some customers experienced across XPM. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Aug 01, 2022 - 08:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2022 - 08:01 UTC
Investigating
We’re currently aware of an issue where some users are experiencing performance issues in Xero Practice Manager. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Aug 01, 2022 - 07:37 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).