Xero Practice Manager - Customers experiencing performance issues
Incident Report for Xero
Resolved
This incident has been resolved.

This was caused by the service experiencing a high level of traffic which meant customers were impacted.
Posted Oct 27, 2022 - 04:22 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 1:50 AM UTC
Posted Oct 27, 2022 - 01:51 UTC
Investigating
We are aware of an issue where customers experiencing performance issues in Xero Practice Manager. Our team is investigating this with urgency.

Status Last Reviewed: 1:16 AM UTC
Posted Oct 27, 2022 - 01:17 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).