Global: Fixed Assets - Some users may experience performance issues
Incident Report for Xero
Resolved
This incident has been resolved.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Feb 02, 2024 - 05:05 UTC
Investigating
We are aware some customers trying to navigate in Fixed Assets are experiencing performance issues. Our team is investigating this with urgency.

Status Last Reviewed: 1:05am UTC
Posted Feb 02, 2024 - 01:05 UTC
This incident affected: Core Xero Products (Fixed Assets).