Global: Products and services - inventory items cannot be accessed
Incident Report for Xero
Resolved
Our team has resolved the issue impacting global customers trying to access inventory items in Products and services in Xero.

This issue related to a prior release that was reverted to resolve customer impact. We apologise for any inconvenience this has caused.
Posted Jun 13, 2024 - 22:32 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 10:20pm UTC
Posted Jun 13, 2024 - 22:20 UTC
Investigating
We are aware global customers trying to access inventory items in the Products and services screen in Xero are experiencing a blank page. Our team is investigating this with urgency.

Status Last Reviewed: 10:00pm UTC
Posted Jun 13, 2024 - 22:00 UTC
This incident affected: Core Xero Products (Products and services).