Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 16, 2025 - 21:00 UTC
Scheduled
Xero will be conducting essential system maintenance on the VAT feature from 9:00 pm UTC until 10:00pm UTC on Sunday, 16th February 2025. Customers will be unable to view or file VAT returns during this time. We apologise for any inconvenience caused.
Posted Feb 10, 2025 - 09:19 UTC
This scheduled maintenance affected: United Kingdom - Regional Products (Tax Reporting - UK VAT & MTD).