Global: Subscription invoices - online invoices not loading
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to load online subscription invoices. This was caused by a recent change, that was reverted to resolve the issue. We apologise for any inconvenience this has caused.
Posted May 31, 2023 - 00:19 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 11:56pm UTC
Posted May 30, 2023 - 23:57 UTC
Investigating
We are aware customers trying to load online subscription invoices are experiencing a blank screen. Our team is investigating this with urgency.

Status Last Reviewed: 11:37pm UTC
Posted May 30, 2023 - 23:39 UTC
This incident affected: Xero Platform and Settings.