Australia customers are unable to see Premium plans in the Xero buy flow
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from seeing Premium plans in the Xero buy flow.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Sep 23, 2020 - 06:00 UTC
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted Sep 23, 2020 - 05:01 UTC
Update
We're currently working to get the Premium plans to appear in the Xero buy flow. Thanks for your continued patience.
Posted Sep 23, 2020 - 04:18 UTC
Identified
Our Product Team have identified the cause, and are working to restore your ability to view the Premium plan as soon as possible.
Posted Sep 23, 2020 - 03:44 UTC
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted Sep 23, 2020 - 03:33 UTC
Update
Our Product Team are doing everything they can to make the Premium plans available again in the Xero buy flow. Thanks for your patience.
Posted Sep 23, 2020 - 02:38 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Sep 23, 2020 - 01:55 UTC
Investigating
We’re currently aware of an issue preventing users from seeing Premium plans in the Xero buy flow. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Sep 23, 2020 - 01:22 UTC
This incident affected: Xero.