WorkflowMax - Some users are experiencing performance issues
Incident Report for Xero
Resolved
Our team has resolved the performance issues some customers experienced across WFM. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted May 10, 2023 - 22:41 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 10:10pm UTC
Posted May 10, 2023 - 22:10 UTC
Investigating
We are aware some customers trying to access WorkflowMax are experiencing performance issues. Our team is investigating this with urgency.

Status Last Reviewed: 10:03pm UTC
Posted May 10, 2023 - 22:03 UTC
This incident affected: WorkflowMax.