Global: Xero Sign & e-signing - Customers experiencing issues
Incident Report for Xero
Resolved
Adobe have now resolved the issue preventing some customers from using Xero Sign, Document Packs, Tax products and the Xero Portal for e-signing documents . We apologise for any inconvenience caused.
Posted Mar 18, 2024 - 12:29 UTC
Investigating
We are aware that customers trying to use Xero Sign, Document Packs, Tax products and the Xero Portal for e-signing documents may be experiencing issues, this is due to an outage that Adobe are experiencing

For more information regarding this please refer to the Adobe status page: https://status.adobe.com/
Posted Mar 18, 2024 - 12:02 UTC
This incident affected: Xero Platform and Settings.