Global: User role changes are delayed
Incident Report for Xero
Resolved
Our team has resolved the issue impacting global customers trying trying to change user roles, invite users and remove users in Xero. We apologise for any inconvenience this has caused.

A product release caused this functionality to become delayed. We've rolled back the release and services are back to normal.
Posted Jun 13, 2024 - 01:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2024 - 01:03 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed:
Posted Jun 13, 2024 - 00:15 UTC
Identified
We have identified what is impacting global customers trying to change user roles, invite users and remove users in Xero. Please note this may be impacting users accessing the Demo Company.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 11:56pm UTC
Posted Jun 12, 2024 - 23:58 UTC
This incident affected: Xero Platform and Settings and Xero Partner Products & Tools (Xero HQ).