Our team has resolved the issue impacting global customers trying to navigate in Hubdoc. We apologise for any inconvenience this has caused.
Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 04, 2024 - 15:45 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 3:33pm UTC
Posted Sep 04, 2024 - 15:33 UTC
Update
We are continuing to work on a fix for this issue. We apologise for the inconvenience this is causing.
Posted Sep 04, 2024 - 15:10 UTC
Identified
We have identified what is impacting some global customers trying to navigate in Hubdoc.
This is our top priority and we will update you as soon as we can.
Status Last Reviewed: 2:40pm UTC
Posted Sep 04, 2024 - 14:40 UTC
Update
We are continuing to investigate this issue.
Posted Sep 04, 2024 - 14:16 UTC
Investigating
We are aware some global customers trying to navigate in Hubdoc are experiencing slowness and performance issues. Our team is investigating this with urgency.