Global: Xero - Customers are experiencing issues in Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting some customers trying to navigate in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Oct 30, 2023 - 01:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2023 - 00:50 UTC

Investigating

We are aware some customers trying to navigate in Xero are experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 11:38pm UTC
Posted Oct 29, 2023 - 22:49 UTC
This incident affected: Xero Platform and Settings.