Some users are experiencing issues loading Xero Dashboard
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users loading the Xero Dashboard.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted May 10, 2022 - 01:04 UTC
Investigating
We’re currently aware of an issue where some users are seeing a blank screen when trying to access the Xero Dashboard. Our Product Team are investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted May 09, 2022 - 21:58 UTC
This incident affected: Xero Platform and Settings.