Global: Payroll - Customers may be experiencing performance issues
Incident Report for Xero
Resolved
This incident has been resolved.

Our technical team identified that this related to network stability issues with our services that several of our Xero products use.
Posted Apr 20, 2023 - 10:24 UTC
Investigating
We are aware some customers trying to access Payroll in Xero are experiencing delays in processing. Our team is investigating this with urgency.

Status Last Reviewed: 10:00 am UTC
Posted Apr 20, 2023 - 10:01 UTC
This incident affected: Australia - Regional Products (AU Payroll), New Zealand - Regional Products (NZ Payroll), and United Kingdom - Regional Products (UK Payroll).