Xero Performance issues
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Nov 30, 2021 - 02:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2021 - 01:04 UTC
Update
We are continuing to investigate this issue.
Posted Nov 30, 2021 - 00:48 UTC
Investigating
We’re currently aware of an issue where users are experiencing issues with the Navigation bar and Bank Reconciliation screen. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 30, 2021 - 00:13 UTC
This incident affected: Xero.