Users are experiencing performance issues in Payroll
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing poor performance in Payroll.

Please let us know if you still have any issues accessing Xero, and we’ll investigate further.
Posted 24 days ago. Nov 20, 2018 - 15:21 NZDT
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted 24 days ago. Nov 20, 2018 - 14:55 NZDT
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 24 days ago. Nov 20, 2018 - 14:33 NZDT
Update
We’re currently aware of an issue affecting the performance of Payroll for some of our users. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 24 days ago. Nov 20, 2018 - 14:18 NZDT
Investigating
We are currently investigating this issue.
Posted 24 days ago. Nov 20, 2018 - 14:16 NZDT
This incident affected: Xero.