We're currently aware of an issue where some users are experiencing slowness and/or a missing navigation bar.
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Nov 03, 2021 - 05:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2021 - 03:47 UTC
Update
We’re aware that users continue to experience slowness and/or are missing the navigation bar. We’re currently investigating the issue.
Posted Nov 03, 2021 - 02:43 UTC
Investigating
We are currently investigating this issue with urgency.
Posted Nov 03, 2021 - 01:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2021 - 01:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 03, 2021 - 00:48 UTC
Investigating
We’re currently aware of an issue where some users are experiencing slowness and/or a missing navigation bar. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 03, 2021 - 00:38 UTC
This incident affected: Xero.