NZ/UK Payroll - Pay History report not loading
Incident Report for Xero
Resolved
Our team has resolved the issue impacting NZ and UK customers trying to run the Payroll - Pay History report. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Nov 14, 2023 - 05:55 UTC
Identified
We have identified what is preventing customers from trying to run the NZ/UK Payroll - Pay History report.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 4:53am UTC
Posted Nov 14, 2023 - 04:54 UTC
Investigating
We are aware some customers trying to run the NZ/UK Payroll - Pay History report not loading. Our team is investigating this with urgency.

Status Last Reviewed: 12:57am UTC
Posted Nov 14, 2023 - 00:47 UTC