Global: Reports - Customers are unable to load Reports
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access Reports. We apologise for any inconvenience this has caused.

A product release caused Reports to become unavailable. We've rolled back the release and services are back to normal.
Posted Feb 23, 2024 - 03:41 UTC
Identified
We have identified what is impacting customers trying to access Reports. This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 3:27am UTC
Posted Feb 23, 2024 - 03:28 UTC
Update
We are continuing to investigate this issue.
Posted Feb 23, 2024 - 03:07 UTC
Investigating
We are aware customers trying to access Reports are experiencing errors. Our team is investigating this with urgency.

Status Last Reviewed: 3:03am UTC
Posted Feb 23, 2024 - 03:04 UTC
This incident affected: Core Xero Products (Reporting).