Global: Error message when managing subscription

Incident Report for Xero

Resolved

Customers are able to access the manage subscription screen again. We resolved the problem by rolling back a release update.

We apologise for any inconvenience this has caused.
Posted Mar 20, 2023 - 12:14 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:00 UTC.
Posted Mar 20, 2023 - 12:00 UTC

Identified

We have identified what is preventing customers trying to manage their subscriptions.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 11:42 UTC.
Posted Mar 20, 2023 - 11:42 UTC

Investigating

We are aware that some customers are receiving errors messages when trying to manage their subscriptions. Our team is investigating this with urgency.

Status Last Reviewed: 11:33 UTC.
Posted Mar 20, 2023 - 10:32 UTC
This incident affected: Xero Platform and Settings.