Degraded performance in Payroll for some users
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing slowness and errors in Xero Payroll.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Mar 26, 2020 - 00:53 UTC
Identified
Our Product Team have identified the cause, and are working to restore your performance to Payroll in Xero as soon as possible.
Posted Mar 26, 2020 - 00:17 UTC
Investigating
We’re currently aware of an issue causing slowness and errors when accessing Payroll in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Mar 25, 2020 - 23:45 UTC
This incident affected: Xero.