Some users are unable to load their Dashboard
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing some users from loading their Dashboard.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Mar 25, 2021 - 02:05 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Mar 25, 2021 - 01:50 UTC
Investigating
We’re currently aware of an issue where some users are unable to load their Dashboard. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Mar 25, 2021 - 01:18 UTC
This incident affected: Xero.