Global: Quotes - some customers may be experiencing a blank page when viewing a Quote
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers trying to access quotes in Xero. We apologise for any inconvenience this has caused.

Our technical team identified that this related to network stability issues with one of the external services that our Xero products use.
Posted Sep 20, 2024 - 21:38 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 20:48 UTC
Posted Sep 20, 2024 - 20:48 UTC
Identified
We have identified what is preventing some customers from accessing Quotes and our team is working on a fix.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 20:42 UTC
Posted Sep 20, 2024 - 15:21 UTC
Investigating
We are aware that some customers are experiencing issues trying to access quotes. Our team is investigating this with urgency.

Status Last Reviewed: 15:02 UTC
Posted Sep 20, 2024 - 10:36 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).