Global: Errors when making subscription changes

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers ability to purchase new Xero organisations and make changes to their subscriptions. This was caused by a recent change that has now been fixed. We apologise for any inconvenience this has caused.
Posted Sep 06, 2023 - 00:16 UTC

Identified

We have identified what is preventing UK customers from being able to purchase new Xero organisations and make changes to their subscriptions.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 10:21pm UTC
Posted Sep 05, 2023 - 18:57 UTC

Investigating

We are aware that UK customers are receiving error messages when trying to make changes to their subscriptions or purchase new organisations. Our team is investigating this with urgency.
Posted Sep 05, 2023 - 13:20 UTC
This incident affected: Xero Platform and Settings.