Global: Xero - Some customers are experiencing slowness

Incident Report for Xero

Resolved

Our team has resolved the slowness affecting customers trying to access Xero. We apologise for any inconvenience this has caused.
Posted Nov 08, 2025 - 21:53 UTC

Update

We are continuing to investigate this with urgency. We appreciate your patience.
Posted Nov 08, 2025 - 21:33 UTC

Investigating

We are aware customers trying to access Xero may be experiencing slowness. Our team is investigating this with urgency.
Posted Nov 08, 2025 - 21:00 UTC
This incident affected: Xero Platform and Settings.