Global: Xero - emails sent from Xero may be delayed
Incident Report for Xero
Resolved
Our team has resolved the issue causing emails sent from Xero to be delayed. This was caused by increased email traffic that our technical teams have now resolved. We apologise for any inconvenience this has caused.
Posted Sep 04, 2023 - 04:32 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 4:12 am UTC
Posted Sep 04, 2023 - 04:12 UTC
Identified
We have identified what is causing a delay on emails sent from Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 3:46 am UTC
Posted Sep 04, 2023 - 03:46 UTC
Investigating
We are aware that emails sent from Xero may be currently delayed. Our team is investigating this with urgency.

Status Last Reviewed: 3:38 am UTC
Posted Sep 04, 2023 - 03:39 UTC
This incident affected: Xero Platform and Settings.