Some users are unable to load reports
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing some users from loading the reports.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Feb 11, 2021 - 03:03 UTC
Investigating
We’re currently aware of an issue preventing some users from loading reports. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Feb 11, 2021 - 02:30 UTC
This incident affected: Xero.