Australia: Payroll - some customers may be unable to access Payroll Settings or Superannuation in Xero

Incident Report for Xero

Update

We're aware that Australian customers are experiencing slow loading and errors on Payroll pages, including Superannuation and Settings. We understand how critical these functions are and our teams are fully focused on restoring access as quickly as possible. We'll provide updates as the situation develops.
Posted Jun 01, 2026 - 10:06 UTC

Update

We're aware that Australian customers are experiencing slow loading and errors on Payroll pages, including Superannuation and Settings. We understand how critical these functions are and our teams are fully focused on restoring access as quickly as possible. We'll provide updates as the situation develops.
Posted Jun 01, 2026 - 08:43 UTC

Investigating

We are aware Australian customers trying to access Payroll pages, including Superannuation or Settings pages, are experiencing loading slowness and eventual errors. Our team is investigating this with urgency.
Posted Jun 01, 2026 - 05:15 UTC
This incident affects: Australia - Regional Products (AU Payroll).