Global: Emails sent from Xero are currently delayed
Incident Report for Xero
Resolved
Our third-party mail provider has resolved the issue causing emails sent from Xero to be delayed in their delivery. We apologise for any inconvenience this has caused.
Posted Feb 21, 2023 - 06:43 UTC
Monitoring
Our third-party mail provider has implemented a fix and we are monitoring the results.
Posted Feb 21, 2023 - 05:50 UTC
Identified
Our third-party mail provider has identified what is causing emails sent from Xero to be delayed in their delivery.

This is their top priority and we will update you as soon as we can.

Status Last Reviewed: 5:42am UTC
Posted Feb 21, 2023 - 05:43 UTC
Investigating
We are aware customers trying to send emails from Xero are currently experiencing a delay in receiving emails. This includes the multi-factor authentication (MFA) verification codes sent to your backup email address when you login.

Our team is investigating this with urgency.

Status Last Reviewed: 4:07am UTC
Posted Feb 21, 2023 - 04:07 UTC
This incident affected: Xero Platform and Settings.